ffmpeg 报错libssl.1.0.0.dylib

背景:

MAC 系统
ffmpeg 去水印

执行图片去水印ffmpeg报错

dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
  Referenced from: /usr/local/bin/ffmpeg
  Reason: image not found
  brew info openssl

ssl提升到1.1版本,但是本地的ffmpeg 依赖1.0版本

切换版本

  brew switch openssl 1.0.2s

第二次报错

dyld: Library not loaded: /usr/local/opt/x265/lib/libx265.179.dylib
  Referenced from: /usr/local/bin/ffmpeg

重装,解决

brew reinstall ffmpeg


This entry was posted in Linux, MAC and tagged . Bookmark the permalink.
月小升QQ 2651044202, 技术交流QQ群 178491360
首发地址:月小升博客https://java-er.com/blog/ffmpeg-error-libssl-1-0-0-dylib/
无特殊说明,文章均为月小升原创,欢迎转载,转载请注明本文地址,谢谢
您的评论是我写作的动力.
2020.03.24 评论已经全局关闭,有事加QQ聊天